Utilizamos Cookies de terceros para generar estadísticas de audiencia y mostrar publicidad personalizada analizando tu navegación. Si sigues navegando estarás aceptando su uso. Más información X
PortadaForo AyudaTutoriales
InicioForosForo Redes de cable

Problema con virtual host en apache

sesiom_23
2006-12-01 00:34 - Respuestas: 0 - Tema nº: 2426923


Saludos, hace poco decidi montar un servidor casero, mediante apache. Usando unos consejos de varias webs, consegui configurar el apache para un solo dominio (el cual adquiri totalmente gratis en www.no-ip.com). Bien el problema llega ahora, que he decidido dar de alta un dominio mas. Lo he intentado de mil maneras con ayuda de internet, pero no consigo configurarlo.

Para un solo dominio bastaba con cambiar en el httpd.conf los parametros que venian por defecto. Pero ahora , e leido por ahi que necesito activar el virtual host y dar de alta los dominios en otro archivo llamado httpd-vhosts.conf.



Mi codigo esta asi (en el httpd-vhosts.conf):
..
# You may use the command line option '-S' to verify your virtual host
# configuration.

Use name-based virtual hosting.

NameVirtualHost *:80


ServerName utilprog.no-ip.org
ServerAlias www.utilprog.no-ip.org (dominio ya existente)
DocumentRoot "D:\My Web"



ServerName cpmmoragues.no-ip.org
ServerAlias www.cpmmoragues.no-ip.org (nuevo dominio)
DocumentRoot "D:\My Web\cpm"

.........................
No se si ademas tengo que tocar algo en el fichero httpd.conf, o si quizas no lo haga bien al dar de alta los vhosts. porque cada vez que intento acceder desde internet al nuevo dominio me sale el index del otro.

Tambien me gustaria saber si hay forma de probar los virtual host desde los ordenadores de mi red local (tengo 3 pcs en un concentrador + router).

Espero puedan orientarme un poco, pues ya no se que hacer ni donde trastear.

Mil gracias por adelantado.

Un saludo!!!

Página:1

Respuestas relacionadas:

Error global virtual card hostError global virtual card hostForo
Global virtual card host (solucionado)Global virtual card host (solucionado)Foro
Problema con el host to host bridgeProblema con el host to host bridgeForo
Problema con apacheProblema con apacheForo
Problema apache tomcatProblema apache tomcatForo
Problema con el apache tomcatProblema con el apache tomcatForo
Problema con apache (xampp)Problema con apache (xampp)Foro
Problema al intentar instalar apacheProblema al intentar instalar apacheForo
Problema windows 7 con apache (appserver)Problema windows 7 con apache (appserver)Foro
Problema con servidor web apache tomcatProblema con servidor web apache tomcatForo
InicioSecciones
^ SubirAviso legal
Política Privacidad
Configurarequipos05 Marzo 2024